728x90

Task

Given a positive integer denoting n, do the following:

  • If 1 ≤ n ≤ 9, print the lowercase English word corresponding to the number (e.g., one for 1, two for 2, etc.).
  • If n > 9, print Greater than 9.

Input Format

The first line contains a single integer, n.

 

Constraints

  • 1 ≤ n ≤ 109

Output Format

  • If 1 ≤ n ≤ 9 , then print the lowercase English word corresponding to the number (e.g., one for 1, two for 2, etc.); otherwise, print Greater than 9 instead.

Sample Input

  • 5

Sample Output

  • five

Sample Input #01

  • 8

Sample Output #01

  • eight

Sample Input #02

  • 44

Sample Output #02

  • Greater than 9

 

#include <assert.h>
#include <limits.h>
#include <math.h>
#include <stdbool.h>
#include <stddef.h>
#include <stdint.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char* readline();


int main()
{
    char* n_endptr;
    char* n_str = readline();
    int n = strtol(n_str, &n_endptr, 10);

    if (n_endptr == n_str || *n_endptr != '\0') { exit(EXIT_FAILURE); }

    // Write Your Code Here
    if (n == 1) {
        printf("%s","one");
    }else if (n == 2) {
        printf("%s","two");
    }else if (n == 3) {
        printf("%s","three");
    }else if (n == 4) {
        printf("%s","four");
    }else if (n == 5) {
        printf("%s","five");
    }else if (n == 6) {
        printf("%s","six");
    }else if (n == 7) {
        printf("%s","seven");
    }else if (n == 8) {
        printf("%s","eight");
    }else if (n == 9) {
        printf("%s","nine");
    }else if (n > 9) {
        printf("%s","Greater than 9");
    }else {
        return 1;
    }

    return 0;
}

char* readline() {
    size_t alloc_length = 1024;
    size_t data_length = 0;
    char* data = malloc(alloc_length);

    while (true) {
        char* cursor = data + data_length;
        char* line = fgets(cursor, alloc_length - data_length, stdin);

        if (!line) { break; }

        data_length += strlen(cursor);

        if (data_length < alloc_length - 1 || data[data_length - 1] == '\n') { break; }

        size_t new_length = alloc_length << 1;
        data = realloc(data, new_length);

        if (!data) { break; }

        alloc_length = new_length;
    }

    if (data[data_length - 1] == '\n') {
        data[data_length - 1] = '\0';
    }

    data = realloc(data, data_length);

    return data;
}

C 조건문 

'Algorithm & Problem solving' 카테고리의 다른 글

For Loop in C  (0) 2021.07.14
Compare the Triplets  (0) 2021.07.06
Simple Array Sum  (0) 2021.07.05
사칙연산 계산기 [Function_recursive call]  (0) 2021.07.05

+ Recent posts